Backwards compatible to Windows 7 and Outlook 2010

With the actual 2.6 release of the Outlook Plugin, we are backwards compatible down to Windows 7 and Outlook 2010.

As always: you have to install the version as “Administrator”…

Leave a Reply

Your email address will not be published. Required fields are marked *